cpp-common/bt2: add basic PluginSet and bt_plugin_find_all_from_dir wrappers
[babeltrace.git] / src / Makefile.am
index 88f54afb9b518e3ef1fa44970043400d7e1e5bf9..dc046d9eab4b826e8e86947327f7a874c1f195be 100644 (file)
@@ -29,10 +29,11 @@ noinst_HEADERS = \
        cpp-common/bt2/message-array.hpp \
        cpp-common/bt2/message-iterator.hpp \
        cpp-common/bt2/message.hpp \
-       cpp-common/bt2/shared-object.hpp \
-       cpp-common/bt2/raw-value-proxy.hpp \
+       cpp-common/bt2/optional-borrowed-object.hpp \
        cpp-common/bt2/plugin-dev.hpp \
+       cpp-common/bt2/plugin.hpp \
        cpp-common/bt2/private-query-executor.hpp \
+       cpp-common/bt2/raw-value-proxy.hpp \
        cpp-common/bt2/self-component-class.hpp \
        cpp-common/bt2/self-component-port.hpp \
        cpp-common/bt2/self-message-iterator-configuration.hpp \
@@ -43,6 +44,7 @@ noinst_HEADERS = \
        cpp-common/bt2/value.hpp \
        cpp-common/bt2/wrap.hpp \
        cpp-common/bt2c/align.hpp \
+       cpp-common/bt2c/c-string-view.hpp \
        cpp-common/bt2c/call.hpp \
        cpp-common/bt2c/endian.hpp \
        cpp-common/bt2c/exc.hpp \
@@ -592,11 +594,15 @@ plugins_utils_babeltrace_plugin_utils_la_SOURCES = \
        plugins/utils/counter/counter.h \
        plugins/utils/dummy/dummy.c \
        plugins/utils/dummy/dummy.h \
-       plugins/utils/muxer/muxer.c \
-       plugins/utils/muxer/muxer.h \
+       plugins/utils/muxer/comp.cpp \
+       plugins/utils/muxer/comp.hpp \
+       plugins/utils/muxer/msg-iter.cpp \
+       plugins/utils/muxer/msg-iter.hpp \
+       plugins/utils/muxer/upstream-msg-iter.cpp \
+       plugins/utils/muxer/upstream-msg-iter.hpp \
        plugins/utils/trimmer/trimmer.c \
        plugins/utils/trimmer/trimmer.h \
-       plugins/utils/plugin.c
+       plugins/utils/plugin.cpp
 
 plugins_utils_babeltrace_plugin_utils_la_LDFLAGS = \
        $(AM_LDFLAGS) \
@@ -610,6 +616,7 @@ if !ENABLE_BUILT_IN_PLUGINS
 plugins_utils_babeltrace_plugin_utils_la_LIBADD += \
        lib/libbabeltrace2.la \
        common/libcommon.la \
+       cpp-common/vendor/fmt/libfmt.la \
        logging/liblogging.la \
        plugins/common/param-validation/libparam-validation.la
 endif
This page took 0.023258 seconds and 4 git commands to generate.