lib: move graph/message/iterator.h -> graph/iterator.h
[babeltrace.git] / src / Makefile.am
index debe1020f585c07113d5332c20779395ec92d8fd..e01f8734eb1710f480fec5ea2aa16507795b3cf3 100644 (file)
@@ -11,56 +11,6 @@ if ENABLE_PYTHON_BINDINGS
 SUBDIRS += bindings/python/bt2
 endif
 
-noinst_HEADERS = \
-       cpp-common/bt2/borrowed-object-iterator.hpp \
-       cpp-common/bt2/borrowed-object-proxy.hpp \
-       cpp-common/bt2/borrowed-object.hpp \
-       cpp-common/bt2/clock-class.hpp \
-       cpp-common/bt2/clock-snapshot.hpp \
-       cpp-common/bt2/component-port.hpp \
-       cpp-common/bt2/exc.hpp \
-       cpp-common/bt2/field-class.hpp \
-       cpp-common/bt2/field-path.hpp \
-       cpp-common/bt2/field.hpp \
-       cpp-common/bt2/integer-range-set.hpp \
-       cpp-common/bt2/integer-range.hpp \
-       cpp-common/bt2/internal/utils.hpp \
-       cpp-common/bt2/logging.hpp \
-       cpp-common/bt2/message-array.hpp \
-       cpp-common/bt2/message-iterator.hpp \
-       cpp-common/bt2/message.hpp \
-       cpp-common/bt2/shared-object.hpp \
-       cpp-common/bt2/raw-value-proxy.hpp \
-       cpp-common/bt2/private-query-executor.hpp \
-       cpp-common/bt2/self-component-class.hpp \
-       cpp-common/bt2/self-component-port.hpp \
-       cpp-common/bt2/self-message-iterator-configuration.hpp \
-       cpp-common/bt2/self-message-iterator.hpp \
-       cpp-common/bt2/shared-object.hpp \
-       cpp-common/bt2/trace-ir.hpp \
-       cpp-common/bt2/type-traits.hpp \
-       cpp-common/bt2/value.hpp \
-       cpp-common/bt2/wrap.hpp \
-       cpp-common/bt2c/align.hpp \
-       cpp-common/bt2c/endian.hpp \
-       cpp-common/bt2c/exc.hpp \
-       cpp-common/bt2c/glib-up.hpp \
-       cpp-common/bt2c/lib-str.hpp \
-       cpp-common/bt2c/libc-up.hpp \
-       cpp-common/bt2c/logging.hpp \
-       cpp-common/bt2c/read-fixed-len-int.hpp \
-       cpp-common/bt2c/safe-ops.hpp \
-       cpp-common/bt2c/std-int.hpp \
-       cpp-common/bt2c/uuid-view.hpp \
-       cpp-common/bt2c/uuid.hpp \
-       cpp-common/bt2c/vector.hpp \
-       cpp-common/bt2s/make-unique.hpp \
-       cpp-common/bt2s/optional.hpp \
-       cpp-common/bt2s/string-view.hpp \
-       cpp-common/vendor/nlohmann/json.hpp \
-       cpp-common/vendor/optional-lite/optional.hpp \
-       cpp-common/vendor/string_view-standalone/string_view.hpp
-
 ## This target generates an include file that contains the git version
 ## string of the current branch, it must be continuously updated when
 ## we build in the git repo and shipped in dist tarballs to reflect the
@@ -103,6 +53,7 @@ noinst_LTLIBRARIES = \
        autodisc/libautodisc.la \
        common/libcommon.la \
        compat/libcompat.la \
+       cpp-common/libcpp-common.la \
        cpp-common/vendor/fmt/libfmt.la \
        ctfser/libctfser.la \
        fd-cache/libfd-cache.la \
@@ -160,6 +111,64 @@ compat_libcompat_la_SOURCES = \
        compat/unistd.h \
        compat/utc.h
 
+cpp_common_libcpp_common_la_SOURCES = \
+       cpp-common/bt2/borrowed-object-iterator.hpp \
+       cpp-common/bt2/borrowed-object-proxy.hpp \
+       cpp-common/bt2/borrowed-object.hpp \
+       cpp-common/bt2/clock-class.hpp \
+       cpp-common/bt2/clock-snapshot.hpp \
+       cpp-common/bt2/component-port.hpp \
+       cpp-common/bt2/exc.hpp \
+       cpp-common/bt2/field-class.hpp \
+       cpp-common/bt2/field-path.hpp \
+       cpp-common/bt2/field.hpp \
+       cpp-common/bt2/integer-range-set.hpp \
+       cpp-common/bt2/integer-range.hpp \
+       cpp-common/bt2/internal/utils.hpp \
+       cpp-common/bt2/logging.hpp \
+       cpp-common/bt2/message-array.hpp \
+       cpp-common/bt2/message-iterator.hpp \
+       cpp-common/bt2/message.hpp \
+       cpp-common/bt2/optional-borrowed-object.hpp \
+       cpp-common/bt2/plugin-dev.hpp \
+       cpp-common/bt2/plugin.hpp \
+       cpp-common/bt2/private-query-executor.hpp \
+       cpp-common/bt2/raw-value-proxy.hpp \
+       cpp-common/bt2/self-component-class.hpp \
+       cpp-common/bt2/self-component-port.hpp \
+       cpp-common/bt2/self-message-iterator-configuration.hpp \
+       cpp-common/bt2/self-message-iterator.hpp \
+       cpp-common/bt2/shared-object.hpp \
+       cpp-common/bt2/trace-ir.hpp \
+       cpp-common/bt2/type-traits.hpp \
+       cpp-common/bt2/value.hpp \
+       cpp-common/bt2/wrap.hpp \
+       cpp-common/bt2c/align.hpp \
+       cpp-common/bt2c/c-string-view.hpp \
+       cpp-common/bt2c/call.hpp \
+       cpp-common/bt2c/dummy.cpp \
+       cpp-common/bt2c/endian.hpp \
+       cpp-common/bt2c/exc.hpp \
+       cpp-common/bt2c/glib-up.hpp \
+       cpp-common/bt2c/lib-str.hpp \
+       cpp-common/bt2c/libc-up.hpp \
+       cpp-common/bt2c/logging.hpp \
+       cpp-common/bt2c/prio-heap.hpp \
+       cpp-common/bt2c/read-fixed-len-int.hpp \
+       cpp-common/bt2c/safe-ops.hpp \
+       cpp-common/bt2c/std-int.hpp \
+       cpp-common/bt2c/type-traits.hpp \
+       cpp-common/bt2c/uuid.hpp \
+       cpp-common/bt2c/vector.hpp \
+       cpp-common/bt2s/make-unique.hpp \
+       cpp-common/bt2s/optional.hpp \
+       cpp-common/bt2s/span.hpp \
+       cpp-common/bt2s/string-view.hpp \
+       cpp-common/vendor/nlohmann/json.hpp \
+       cpp-common/vendor/optional-lite/optional.hpp \
+       cpp-common/vendor/span-lite/span.hpp \
+       cpp-common/vendor/string_view-standalone/string_view.hpp
+
 cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/args.h \
        cpp-common/vendor/fmt/chrono.h \
@@ -369,7 +378,6 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/graph/message/event.h \
        lib/graph/message-iterator-class.c \
        lib/graph/message-iterator-class.h \
-       lib/graph/message/iterator.h \
        lib/graph/message/message.c \
        lib/graph/message/message.h \
        lib/graph/message/message-iterator-inactivity.c \
@@ -399,6 +407,7 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/graph/interrupter.c \
        lib/graph/interrupter.h \
        lib/graph/iterator.c \
+       lib/graph/iterator.h \
        lib/graph/mip.c \
        lib/graph/port.c \
        lib/graph/port.h \
@@ -408,8 +417,6 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/plugin/plugin.h \
        lib/plugin/plugin-so.c \
        lib/plugin/plugin-so.h \
-       lib/prio-heap/prio-heap.c \
-       lib/prio-heap/prio-heap.h \
        lib/trace-ir/attributes.c \
        lib/trace-ir/attributes.h \
        lib/trace-ir/clock-class.c \
@@ -592,11 +599,15 @@ plugins_utils_babeltrace_plugin_utils_la_SOURCES = \
        plugins/utils/counter/counter.h \
        plugins/utils/dummy/dummy.c \
        plugins/utils/dummy/dummy.h \
-       plugins/utils/muxer/muxer.c \
-       plugins/utils/muxer/muxer.h \
+       plugins/utils/muxer/comp.cpp \
+       plugins/utils/muxer/comp.hpp \
+       plugins/utils/muxer/msg-iter.cpp \
+       plugins/utils/muxer/msg-iter.hpp \
+       plugins/utils/muxer/upstream-msg-iter.cpp \
+       plugins/utils/muxer/upstream-msg-iter.hpp \
        plugins/utils/trimmer/trimmer.c \
        plugins/utils/trimmer/trimmer.h \
-       plugins/utils/plugin.c
+       plugins/utils/plugin.cpp
 
 plugins_utils_babeltrace_plugin_utils_la_LDFLAGS = \
        $(AM_LDFLAGS) \
@@ -610,6 +621,7 @@ if !ENABLE_BUILT_IN_PLUGINS
 plugins_utils_babeltrace_plugin_utils_la_LIBADD += \
        lib/libbabeltrace2.la \
        common/libcommon.la \
+       cpp-common/vendor/fmt/libfmt.la \
        logging/liblogging.la \
        plugins/common/param-validation/libparam-validation.la
 endif
@@ -735,4 +747,6 @@ plugins_lttng_utils_babeltrace_plugin_lttng_utils_la_LIBADD += \
 endif # !ENABLE_BUILT_IN_PLUGINS
 endif # ENABLE_DEBUG_INFO
 
-EXTRA_DIST = cpp-common/optional.hpp.license
+EXTRA_DIST = \
+       cpp-common/vendor/optional-lite/optional.hpp.license \
+       cpp-common/vendor/span-lite/span.hpp.license
This page took 0.025441 seconds and 4 git commands to generate.