Show python bindings install output in verbose builds
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index ec30c005c91468215470cc9306cfdad23809099f..124fadaf47d813eb6b25a2bb4f424204f7fae09b 100644 (file)
@@ -3,7 +3,7 @@
 # Since the shared object used by the python bindings is not built with
 # libtool, we need to add the directory containing libbabeltrace2 to the
 # linker path.
-AM_LDFLAGS=-L$(top_builddir)/src/lib/.libs
+AM_LDFLAGS += -L$(top_builddir)/src/lib/.libs
 
 INSTALLED_FILES=$(builddir)/installed_files.txt
 
@@ -119,6 +119,9 @@ WARN_CFLAGS += -Wno-null-dereference
 # code.
 WARN_CFLAGS += -Wno-deprecated-declarations
 
+# Python 3.11 + gcc 12.2.0 gave warnings of this kind in Python.h.
+WARN_CFLAGS += -Wno-redundant-decls
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
@@ -148,8 +151,12 @@ $(builddir)/bt2/native_bt.c: $(SWIG_INTERFACE_FILES)
 
 -include bt2/native_bt.d
 
+pyinstall_verbose = $(pyinstall_verbose_@AM_V@)
+pyinstall_verbose_ = $(pyinstall_verbose_@AM_DEFAULT_V@)
+pyinstall_verbose_0 = @
+
 install-exec-local: build-python-bindings.stamp
-       @opts="--prefix=$(prefix) --record $(INSTALLED_FILES) --verbose --no-compile $(DISTSETUPOPTS)"; \
+       $(pyinstall_verbose)opts="--prefix=$(prefix) --record $(INSTALLED_FILES) --verbose --no-compile $(DISTSETUPOPTS)"; \
        if [ "$(DESTDIR)" != "" ]; then \
                opts="$$opts --root=$(DESTDIR)"; \
        fi; \
This page took 0.023853 seconds and 4 git commands to generate.