bt2: honor build system compiler/linker preferences
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index 6dc518d2ba5d194a68029823d32ed64ea0b21773..20f142e4e07004a4e5065c7b4c2e0b95509d5a97 100644 (file)
@@ -123,7 +123,7 @@ WARN_CFLAGS += -Wno-redundant-decls
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
-               LDFLAGS="$(AM_LDFLAGS) $(LDFLAGS) $(GLIB_LIBS) $(LIBS)"
+               LDFLAGS="$(AM_LDFLAGS) $(LDFLAGS) $(GLIB_LIBS) $(PYTHON_LDFLAGS) $(LIBS)"
 
 all-local: build-python-bindings.stamp
 
@@ -150,7 +150,7 @@ $(builddir)/bt2/native_bt.c: $(SWIG_INTERFACE_FILES)
 -include bt2/native_bt.d
 
 install-exec-local: build-python-bindings.stamp
-       @opts="--prefix=$(prefix) --record $(INSTALLED_FILES) --verbose --no-compile $(DISTSETUPOPTS)"; \
+       @opts="--prefix=$(prefix) --exec-prefix=$(exec_prefix) --record $(INSTALLED_FILES) --verbose --no-compile $(DISTSETUPOPTS)"; \
        if [ "$(DESTDIR)" != "" ]; then \
                opts="$$opts --root=$(DESTDIR)"; \
        fi; \
This page took 0.023812 seconds and 4 git commands to generate.