Fix: disable deprecation warnings for SWIG generated code
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index cc0ded098e8638f9254f9b31e2e72bcfbebadbae..7efab895abd069c095584bb4877ca18acba4e6c9 100644 (file)
@@ -17,6 +17,7 @@ SWIG_INTERFACE_FILES =                                        \
        bt2/native_bt_component_class.i.h               \
        bt2/native_bt_connection.i                      \
        bt2/native_bt_error.i                           \
+       bt2/native_bt_error.i.h                         \
        bt2/native_bt_event.i                           \
        bt2/native_bt_event_class.i                     \
        bt2/native_bt_field.i                           \
@@ -94,7 +95,8 @@ STATIC_LIBRARIES_DEPS = \
        $(top_builddir)/src/autodisc/libbabeltrace2-autodisc.la \
        $(top_builddir)/src/logging/libbabeltrace2-logging.la \
        $(top_builddir)/src/common/libbabeltrace2-common.la \
-       $(top_builddir)/src/py-common/libbabeltrace2-py-common.la
+       $(top_builddir)/src/py-common/libbabeltrace2-py-common.la \
+       $(top_builddir)/src/string-format/libbabeltrace2-string-format.la
 
 GENERATED_BINDINGS_DEPS =      \
        bt2/native_bt.c         \
@@ -108,6 +110,13 @@ GENERATED_BINDINGS_DEPS =  \
 # Disable -Wshadow for that file.
 WARN_CFLAGS = -Wno-shadow
 
+WARN_CFLAGS += -Wno-null-dereference
+
+# Python 3.8 with SWIG 4.0.2 generates a deprecated warning for 'tp_print'
+# and in general there is not much we can do about deprecations in generated
+# code.
+WARN_CFLAGS += -Wno-deprecated-declarations
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.025273 seconds and 4 git commands to generate.