Move to kernel style SPDX license identifiers
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index ccd56bbbaec30e1f0a34bbf965d4c472627f869f..ab5b77955492fe6a7a88c3ce107862bea175e12f 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 # Since the shared object used by the python bindings is not built with
 # libtool, we need to add the directory containing libbabeltrace2 to the
 # linker path.
@@ -110,10 +112,12 @@ GENERATED_BINDINGS_DEPS = \
 # Disable -Wshadow for that file.
 WARN_CFLAGS = -Wno-shadow
 
+WARN_CFLAGS += -Wno-null-dereference
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
-               LDFLAGS="$(AM_LDFLAGS) $(LDFLAGS) $(GLIB_LIBS) $(LIBS)"
+               LDFLAGS="$(AM_LDFLAGS) $(LDFLAGS) $(GLIB_LIBS) $(PYTHON_LDFLAGS) $(LIBS)"
 
 all-local: build-python-bindings.stamp
 
This page took 0.025782 seconds and 4 git commands to generate.