bt2: ignore -Wredundant-decls warning
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index c8e3eb44ae99e391fba19fccd46b1d7048a00a9a..aec0770bdcb3db5d819a4d083c7312f740311b5a 100644 (file)
@@ -119,6 +119,9 @@ WARN_CFLAGS += -Wno-null-dereference
 # code.
 WARN_CFLAGS += -Wno-deprecated-declarations
 
+# Python 3.11 + gcc 12.2.0 gave warnings of this kind in Python.h.
+WARN_CFLAGS += -Wno-redundant-decls
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.023222 seconds and 4 git commands to generate.