bt2: make bt2.Error wrap current thread's error
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index 0324ed2483804129a5d83326e4ea2440757e51be..c8719d66b5e753cc6315bc18a040af9c361147a8 100644 (file)
@@ -12,6 +12,7 @@ SWIG_INTERFACE_FILES =                                        \
        bt2/native_bt_component_class.i                 \
        bt2/native_bt_component.i                       \
        bt2/native_bt_connection.i                      \
+       bt2/native_bt_error.i                           \
        bt2/native_bt_event_class.i                     \
        bt2/native_bt_event.i                           \
        bt2/native_bt_field_class.i                     \
@@ -44,6 +45,7 @@ STATIC_BINDINGS_DEPS =                                        \
        bt2/clock_snapshot.py                           \
        bt2/component.py                                \
        bt2/connection.py                               \
+       bt2/error.py                                    \
        bt2/event_class.py                              \
        bt2/event.py                                    \
        bt2/field.py                                    \
@@ -68,6 +70,13 @@ STATIC_BINDINGS_DEPS =                                       \
        bt2/utils.py                                    \
        bt2/value.py
 
+# Convenience static libraries on which the Python bindings library depends.
+# These are listed in the setup.py(.in) file.
+STATIC_LIBRARIES_DEPS = \
+       $(top_builddir)/src/logging/libbabeltrace2-logging.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/py-common/libbabeltrace2-py-common.la
+
 GENERATED_BINDINGS_DEPS =      \
        bt2/__init__.py         \
        bt2/native_bt.c         \
@@ -88,7 +97,8 @@ copy-static-deps.stamp: $(addprefix $(srcdir)/, $(STATIC_BINDINGS_DEPS))
        fi
        touch $@
 
-build-python-bindings.stamp: copy-static-deps.stamp $(GENERATED_BINDINGS_DEPS) $(STATIC_NATIVE_LIB_SRCS)
+build-python-bindings.stamp: copy-static-deps.stamp $(GENERATED_BINDINGS_DEPS) \
+               $(STATIC_NATIVE_LIB_SRCS) $(STATIC_LIBRARIES_DEPS)
        $(BUILD_FLAGS) $(PYTHON) $(builddir)/setup.py build --force
        touch $@
 
This page took 0.025337 seconds and 4 git commands to generate.