Add --enable-asan configure option
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index d89907ce7d323376ecbe54d600be999a875400b6..c8e3eb44ae99e391fba19fccd46b1d7048a00a9a 100644 (file)
@@ -1,7 +1,9 @@
+# SPDX-License-Identifier: MIT
+
 # Since the shared object used by the python bindings is not built with
 # libtool, we need to add the directory containing libbabeltrace2 to the
 # linker path.
-AM_LDFLAGS=-L$(top_builddir)/src/lib/.libs
+AM_LDFLAGS += -L$(top_builddir)/src/lib/.libs
 
 INSTALLED_FILES=$(builddir)/installed_files.txt
 
@@ -112,6 +114,11 @@ WARN_CFLAGS = -Wno-shadow
 
 WARN_CFLAGS += -Wno-null-dereference
 
+# Python 3.8 with SWIG 4.0.2 generates a deprecated warning for 'tp_print'
+# and in general there is not much we can do about deprecations in generated
+# code.
+WARN_CFLAGS += -Wno-deprecated-declarations
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.02372 seconds and 4 git commands to generate.