bt2: Makefile: track dependencies of native_bt.c
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index c74988b14819dc8dd3497deed0ab21aa0c5e551c..e97213455918ec2dccb212ee1942f370beebe537 100644 (file)
@@ -126,7 +126,9 @@ swig_verbose_ = $(swig_verbose_@AM_DEFAULT_V@)
 swig_verbose_0 = @echo "  SWIG     " $@;
 
 $(builddir)/bt2/native_bt.c: $(SWIG_INTERFACE_FILES)
-       $(swig_verbose)$(SWIG) -python -I"$(top_srcdir)/include" -o "$@" "$<"
+       $(swig_verbose)$(SWIG) -MD -python -I"$(top_srcdir)/include" -o "$@" "$<"
+
+-include bt2/native_bt.d
 
 install-exec-local: build-python-bindings.stamp
        @opts="--prefix=$(prefix) --record $(INSTALLED_FILES) --verbose --no-compile $(DISTSETUPOPTS)"; \
This page took 0.02288 seconds and 4 git commands to generate.