Fix: disable deprecation warnings for SWIG generated code
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index ab5b77955492fe6a7a88c3ce107862bea175e12f..ec30c005c91468215470cc9306cfdad23809099f 100644 (file)
@@ -114,6 +114,11 @@ WARN_CFLAGS = -Wno-shadow
 
 WARN_CFLAGS += -Wno-null-dereference
 
+# Python 3.8 with SWIG 4.0.2 generates a deprecated warning for 'tp_print'
+# and in general there is not much we can do about deprecations in generated
+# code.
+WARN_CFLAGS += -Wno-deprecated-declarations
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.023497 seconds and 4 git commands to generate.