Add --enable-asan configure option
[babeltrace.git] / src / cli / Makefile.am
index bc7627e91808c74c2e2f1c90900e4199a3594348..2428b489e62d6a9e320c05ec91ebd759ed5a2175 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 PLUGINS_PATH = $(abs_top_builddir)/src/plugins
 LTTNG_UTILS_PLUGIN_PATH =
 
@@ -30,8 +32,6 @@ babeltrace2_bin_SOURCES = \
        babeltrace2-cfg-cli-args-connect.h \
        babeltrace2-cfg-cli-args-default.h \
        babeltrace2-cfg-cli-args-default.c \
-       babeltrace2-cfg-cli-params-arg.c \
-       babeltrace2-cfg-cli-params-arg.h \
        babeltrace2-log-level.c \
        babeltrace2-log-level.h \
        babeltrace2-plugins.c \
@@ -44,7 +44,7 @@ babeltrace2_bin_SOURCES = \
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-babeltrace2_bin_LDFLAGS = $(LD_NO_AS_NEEDED)
+babeltrace2_bin_LDFLAGS = $(AM_LDFLAGS) $(LD_NO_AS_NEEDED)
 
 # Add all the convenience libraries used by Babeltrace plugins and the
 # library. They will be used when embedding plugins (--enable-built-in-plugins),
@@ -54,8 +54,10 @@ babeltrace2_bin_LDFLAGS = $(LD_NO_AS_NEEDED)
 # not discard the plugins since the CLI does not use their symbols
 # directly).
 babeltrace2_bin_LDADD = \
-       $(top_builddir)/src/argpar/libbabeltrace2-argpar.la \
+       $(top_builddir)/src/argpar/libargpar.la \
        $(top_builddir)/src/autodisc/libbabeltrace2-autodisc.la \
+       $(top_builddir)/src/param-parse/libbabeltrace2-param-parse.la \
+       $(top_builddir)/src/string-format/libbabeltrace2-string-format.la \
        $(top_builddir)/src/lib/libbabeltrace2.la \
        $(top_builddir)/src/compat/libcompat.la \
        $(top_builddir)/src/common/libbabeltrace2-common.la \
This page took 0.023048 seconds and 4 git commands to generate.