Add --enable-asan configure option
[babeltrace.git] / src / cli / Makefile.am
index e5567843fcba6266bf56e3f27795583f61788592..2428b489e62d6a9e320c05ec91ebd759ed5a2175 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 PLUGINS_PATH = $(abs_top_builddir)/src/plugins
 LTTNG_UTILS_PLUGIN_PATH =
 
@@ -42,7 +44,7 @@ babeltrace2_bin_SOURCES = \
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-babeltrace2_bin_LDFLAGS = $(LD_NO_AS_NEEDED)
+babeltrace2_bin_LDFLAGS = $(AM_LDFLAGS) $(LD_NO_AS_NEEDED)
 
 # Add all the convenience libraries used by Babeltrace plugins and the
 # library. They will be used when embedding plugins (--enable-built-in-plugins),
@@ -52,14 +54,15 @@ babeltrace2_bin_LDFLAGS = $(LD_NO_AS_NEEDED)
 # not discard the plugins since the CLI does not use their symbols
 # directly).
 babeltrace2_bin_LDADD = \
-       $(top_builddir)/src/argpar/libbabeltrace2-argpar.la \
+       $(top_builddir)/src/argpar/libargpar.la \
        $(top_builddir)/src/autodisc/libbabeltrace2-autodisc.la \
+       $(top_builddir)/src/param-parse/libbabeltrace2-param-parse.la \
+       $(top_builddir)/src/string-format/libbabeltrace2-string-format.la \
        $(top_builddir)/src/lib/libbabeltrace2.la \
        $(top_builddir)/src/compat/libcompat.la \
        $(top_builddir)/src/common/libbabeltrace2-common.la \
        $(top_builddir)/src/logging/libbabeltrace2-logging.la \
-       $(top_builddir)/src/ctfser/libbabeltrace2-ctfser.la \
-       $(top_builddir)/src/param-parse/libbabeltrace2-param-parse.la
+       $(top_builddir)/src/ctfser/libbabeltrace2-ctfser.la
 
 if ENABLE_BUILT_IN_PLUGINS
 # Takes a plugin name and outputs the needed LDFLAGS to embed it.
This page took 0.024166 seconds and 4 git commands to generate.