Add --enable-asan configure option
[babeltrace.git] / src / lib / Makefile.am
index c00a0ee16fd0de6a98c5221b78226d817928c9c4..a91138103b43c3d40592e38255ab67c1e3fb7314 100644 (file)
@@ -1,12 +1,20 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS = trace-ir prio-heap plugin graph
 
 lib_LTLIBRARIES = libbabeltrace2.la
 
 libbabeltrace2_la_SOURCES = \
-       assert-post.h \
-       assert-pre.h \
+       assert-cond-base.h \
+       assert-cond.h \
+       assert-cond.c \
        babeltrace2.c \
+       current-thread.c \
+       error.c \
+       error.h \
        func-status.h \
+       integer-range-set.c \
+       integer-range-set.h \
        lib-logging.c \
        logging.c \
        logging.h \
@@ -18,8 +26,10 @@ libbabeltrace2_la_SOURCES = \
        value.c \
        value.h
 
-libbabeltrace2_la_LDFLAGS = $(LT_NO_UNDEFINED) \
-                       -version-info $(BABELTRACE_LIBRARY_VERSION)
+libbabeltrace2_la_LDFLAGS = \
+       $(AM_LDFLAGS) \
+       $(LT_NO_UNDEFINED) \
+       -version-info $(BABELTRACE_LIBRARY_VERSION)
 
 libbabeltrace2_la_LIBADD = \
        prio-heap/libprio-heap.la \
@@ -31,5 +41,5 @@ libbabeltrace2_la_LIBADD = \
        $(top_builddir)/src/compat/libcompat.la
 
 if ENABLE_BUILT_IN_PYTHON_PLUGIN_SUPPORT
-libbabeltrace2_la_LIBADD += $(top_builddir)/src/python-plugin-provider/libbabeltrace2-python-plugin-provider.la
+libbabeltrace2_la_LIBADD += $(top_builddir)/src/python-plugin-provider/babeltrace2-python-plugin-provider.la
 endif
This page took 0.023397 seconds and 4 git commands to generate.