Move to kernel style SPDX license identifiers
[babeltrace.git] / src / plugins / ctf / common / metadata / Makefile.am
index 0de440519329c2866d73d883138af55e42bfee98..5d2db270e3afb1e40a95b85169f01ccb5162c276 100644 (file)
@@ -1,5 +1,7 @@
+# SPDX-License-Identifier: MIT
+
 AM_CPPFLAGS += -I$(builddir) -I$(srcdir)
-AM_YFLAGS = -t -d -v
+AM_YFLAGS = -t -d -v -Wno-yacc
 
 noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
@@ -10,7 +12,12 @@ libctf_parser_la_SOURCES = lexer.l parser.y objstack.c
 # with bt_.
 libctf_parser_la_CPPFLAGS = $(AM_CPPFLAGS) \
                -include $(srcdir)/scanner-symbols.h
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -Wno-unused-function
+
+# This library contains (mostly) generated code, silence some warnings that it
+# produces.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) \
+       -Wno-unused-function \
+       -Wno-null-dereference
 
 libctf_ast_la_SOURCES = \
        visitor-generate-ir.c \
@@ -19,11 +26,13 @@ libctf_ast_la_SOURCES = \
        ast.h \
        objstack.h \
        parser.h \
+       parser-wrap.h \
        scanner.h \
        scanner-symbols.h \
        decoder.c \
-       decoder-packetized-file-stream-to-buf.c \
        decoder.h \
+       decoder-packetized-file-stream-to-buf.c \
+       decoder-packetized-file-stream-to-buf.h \
        logging.c \
        logging.h \
        ctf-meta.h \
@@ -37,12 +46,12 @@ libctf_ast_la_SOURCES = \
        ctf-meta-update-stream-class-config.c \
        ctf-meta-warn-meaningless-header-fields.c \
        ctf-meta-translate.c \
-       ctf-meta-resolve.c
-
-libctf_ast_la_LIBADD = $(UUID_LIBS)
+       ctf-meta-resolve.c \
+       ctf-meta-configure-ir-trace.c \
+       ctf-meta-configure-ir-trace.h
 
 if BABELTRACE_BUILD_WITH_MINGW
-libctf_ast_la_LIBADD += -lrpcrt4 -lintl -liconv -lole32 $(POPT_LIBS)
+libctf_ast_la_LIBADD = -lintl -liconv -lole32
 endif
 
 # start with empty files to clean
This page took 0.0265 seconds and 4 git commands to generate.