Move to kernel style SPDX license identifiers
[babeltrace.git] / src / plugins / ctf / common / metadata / Makefile.am
index d37b3835a590d43f540108a07975b904ed1f1d62..5d2db270e3afb1e40a95b85169f01ccb5162c276 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 AM_CPPFLAGS += -I$(builddir) -I$(srcdir)
 AM_YFLAGS = -t -d -v -Wno-yacc
 
@@ -10,7 +12,12 @@ libctf_parser_la_SOURCES = lexer.l parser.y objstack.c
 # with bt_.
 libctf_parser_la_CPPFLAGS = $(AM_CPPFLAGS) \
                -include $(srcdir)/scanner-symbols.h
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -Wno-unused-function
+
+# This library contains (mostly) generated code, silence some warnings that it
+# produces.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) \
+       -Wno-unused-function \
+       -Wno-null-dereference
 
 libctf_ast_la_SOURCES = \
        visitor-generate-ir.c \
@@ -23,8 +30,9 @@ libctf_ast_la_SOURCES = \
        scanner.h \
        scanner-symbols.h \
        decoder.c \
-       decoder-packetized-file-stream-to-buf.c \
        decoder.h \
+       decoder-packetized-file-stream-to-buf.c \
+       decoder-packetized-file-stream-to-buf.h \
        logging.c \
        logging.h \
        ctf-meta.h \
This page took 0.023991 seconds and 4 git commands to generate.