Move to kernel style SPDX license identifiers
[babeltrace.git] / src / plugins / ctf / common / metadata / Makefile.am
index efbd50b91d9a32fae5a6f5d1776dde9afe67c15f..5d2db270e3afb1e40a95b85169f01ccb5162c276 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 AM_CPPFLAGS += -I$(builddir) -I$(srcdir)
 AM_YFLAGS = -t -d -v -Wno-yacc
 
@@ -10,7 +12,12 @@ libctf_parser_la_SOURCES = lexer.l parser.y objstack.c
 # with bt_.
 libctf_parser_la_CPPFLAGS = $(AM_CPPFLAGS) \
                -include $(srcdir)/scanner-symbols.h
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -Wno-unused-function
+
+# This library contains (mostly) generated code, silence some warnings that it
+# produces.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) \
+       -Wno-unused-function \
+       -Wno-null-dereference
 
 libctf_ast_la_SOURCES = \
        visitor-generate-ir.c \
This page took 0.024554 seconds and 4 git commands to generate.