port: add 'notext' keyword linker support
[babeltrace.git] / src / plugins / text / Makefile.am
index 7ba0037177725d18ee74ee665e601b9580d2e4d9..9d8ed88dd84ab00391df49789c847ff04f636702 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS = pretty dmesg details
 
 plugindir = "$(BABELTRACE_PLUGINS_DIR)"
@@ -6,7 +8,7 @@ plugin_LTLIBRARIES = babeltrace-plugin-text.la
 babeltrace_plugin_text_la_SOURCES = plugin.c
 babeltrace_plugin_text_la_LDFLAGS = \
        $(LT_NO_UNDEFINED) \
-       -avoid-version -module
+       -avoid-version -module $(LD_NOTEXT)
 
 babeltrace_plugin_text_la_LIBADD = \
        pretty/libbabeltrace2-plugin-text-pretty-cc.la \
This page took 0.023634 seconds and 4 git commands to generate.