Add --enable-asan configure option
[babeltrace.git] / src / plugins / text / Makefile.am
index 7ba0037177725d18ee74ee665e601b9580d2e4d9..9e69ad8016aed8bc38eee57dab8f88459a7b4dc8 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS = pretty dmesg details
 
 plugindir = "$(BABELTRACE_PLUGINS_DIR)"
@@ -5,8 +7,9 @@ plugin_LTLIBRARIES = babeltrace-plugin-text.la
 
 babeltrace_plugin_text_la_SOURCES = plugin.c
 babeltrace_plugin_text_la_LDFLAGS = \
+       $(AM_LDFLAGS) \
        $(LT_NO_UNDEFINED) \
-       -avoid-version -module
+       -avoid-version -module $(LD_NOTEXT)
 
 babeltrace_plugin_text_la_LIBADD = \
        pretty/libbabeltrace2-plugin-text-pretty-cc.la \
This page took 0.023126 seconds and 4 git commands to generate.