Add parameter validation utility
[babeltrace.git] / tests / Makefile.am
index 24c89fbeb9388c6bea9d48e257d1e389f1053d65..11b932c8094a78426b9e490a35e697e88e9e8f1a 100644 (file)
@@ -1,4 +1,11 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins argpar
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -35,6 +42,7 @@ dist_check_SCRIPTS = \
        cli/convert/test_auto_source_discovery_params \
        cli/convert/test_auto_source_discovery_log_level \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
        cli/test_output_path_ctf_non_lttng_trace \
@@ -42,6 +50,8 @@ dist_check_SCRIPTS = \
        cli/test_trace_copy \
        cli/test_trace_read \
        cli/test_trimmer \
+       plugins/sink.text.details/succeed/test_succeed \
+       plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
        python-plugin-provider/test_python_plugin_provider.py
@@ -57,6 +67,7 @@ TESTS_ARGPAR = \
 
 TESTS_CLI = \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_path_ctf_non_lttng_trace \
        cli/test_packet_seq_num \
@@ -83,7 +94,8 @@ endif
 
 TESTS_PLUGINS = \
        plugins/src.ctf.fs/succeed/test_succeed \
-       plugins/sink.ctf.fs/succeed/test_succeed
+       plugins/sink.ctf.fs/succeed/test_succeed \
+       plugins/sink.text.details/succeed/test_succeed
 
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
@@ -120,6 +132,10 @@ TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming \
 endif
 endif
 
+if HAVE_PYTHON
+TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+endif
+
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
This page took 0.024062 seconds and 4 git commands to generate.