Add parameter validation utility
[babeltrace.git] / tests / Makefile.am
index 6142a03b9cca90e95dc7506fc55bfc0ff3dcd80f..11b932c8094a78426b9e490a35e697e88e9e8f1a 100644 (file)
@@ -1,4 +1,11 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins argpar
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -35,6 +42,7 @@ dist_check_SCRIPTS = \
        cli/convert/test_auto_source_discovery_params \
        cli/convert/test_auto_source_discovery_log_level \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
        cli/test_output_path_ctf_non_lttng_trace \
@@ -59,6 +67,7 @@ TESTS_ARGPAR = \
 
 TESTS_CLI = \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_path_ctf_non_lttng_trace \
        cli/test_packet_seq_num \
This page took 0.025335 seconds and 4 git commands to generate.