Add parameter validation utility
[babeltrace.git] / tests / Makefile.am
index c2bf42a58161d91e914f628e2c31fb6426f3ba51..11b932c8094a78426b9e490a35e697e88e9e8f1a 100644 (file)
@@ -1,6 +1,11 @@
-#5149916
-
-SUBDIRS = utils lib bitfield ctf-writer plugins
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -18,8 +23,10 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_field.py \
        bindings/python/bt2/test_graph.py \
        bindings/python/bt2/test_integer_range_set.py \
+       bindings/python/bt2/test_interrupter.py \
        bindings/python/bt2/test_message_iterator.py \
        bindings/python/bt2/test_message.py \
+       bindings/python/bt2/test_package.py \
        bindings/python/bt2/test_packet.py \
        bindings/python/bt2/test_plugin.py \
        bindings/python/bt2/test_port.py \
@@ -31,13 +38,20 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_trace.py \
        bindings/python/bt2/test_value.py \
        bindings/python/bt2/utils.py \
-       cli/test_convert_args \
+       cli/convert/test_auto_source_discovery_grouping \
+       cli/convert/test_auto_source_discovery_params \
+       cli/convert/test_auto_source_discovery_log_level \
+       cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
+       cli/test_output_path_ctf_non_lttng_trace \
        cli/test_packet_seq_num \
        cli/test_trace_copy \
        cli/test_trace_read \
        cli/test_trimmer \
+       plugins/sink.text.details/succeed/test_succeed \
+       plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
        python-plugin-provider/test_python_plugin_provider.py
@@ -48,19 +62,25 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
+TESTS_ARGPAR = \
+       argpar/test_argpar
+
 TESTS_CLI = \
-       cli/test_trace_read \
-       cli/test_packet_seq_num \
-       cli/test_convert_args \
+       cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
+       cli/test_output_path_ctf_non_lttng_trace \
+       cli/test_packet_seq_num \
        cli/test_trace_copy \
+       cli/test_trace_read \
        cli/test_trimmer
 
 TESTS_LIB = \
        lib/test_bt_values \
        lib/test_bt_uuid \
        lib/test_graph_topo \
-       lib/test_trace_ir_ref
+       lib/test_trace_ir_ref \
+       lib/test_simple_sink
 
 TESTS_BITFIELD = \
        bitfield/test_bitfield
@@ -74,11 +94,14 @@ endif
 
 TESTS_PLUGINS = \
        plugins/src.ctf.fs/succeed/test_succeed \
-       plugins/sink.ctf.fs/succeed/test_succeed
+       plugins/sink.ctf.fs/succeed/test_succeed \
+       plugins/sink.text.details/succeed/test_succeed
 
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
-TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query
+TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_support_info
+TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_trace_info
+TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_metadata_info
 endif
 
 if ENABLE_DEBUG_INFO
@@ -101,10 +124,18 @@ endif
 
 if ENABLE_PYTHON_PLUGINS
 if ENABLE_PYTHON_BINDINGS
-TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming
+TESTS_CLI += cli/convert/test_auto_source_discovery_grouping \
+       cli/convert/test_auto_source_discovery_log_level \
+       cli/convert/test_auto_source_discovery_params
+TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming \
+       plugins/flt.utils.muxer/succeed/test_succeed
 endif
 endif
 
+if HAVE_PYTHON
+TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+endif
+
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
@@ -118,10 +149,12 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_AWK_BIN="$(AWK)" \
             BT_TESTS_GREP_BIN="$(GREP)" \
             BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
             BT_TESTS_SED_BIN="$(SED)" \
             $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
+       $(TESTS_ARGPAR) \
        $(TESTS_BINDINGS) \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
@@ -136,6 +169,7 @@ check-$(1):
        $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
 endef
 
+$(eval $(call check_target,argpar,$(TESTS_ARGPAR)))
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
This page took 0.024254 seconds and 4 git commands to generate.