Fix: actually run the param validation test
[babeltrace.git] / tests / Makefile.am
index 92ff89e15287e42abd3f93378c68a88e35686b47..1550d22909e28fe08a81dc253566486ce93216f1 100644 (file)
@@ -1,4 +1,11 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins argpar
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -135,6 +142,9 @@ if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
 endif
 
+TESTS_PARAM_VALIDATION = \
+       param-validation/test_param_validation
+
 LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
@@ -152,6 +162,7 @@ TESTS_NO_BITFIELD = \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
        $(TESTS_LIB) \
+       $(TESTS_PARAM_VALIDATION) \
        $(TESTS_PLUGINS) \
        $(TESTS_PYTHON_PLUGIN_PROVIDER)
 
This page took 0.023416 seconds and 4 git commands to generate.