Add a single generated env file to the test suite
[babeltrace.git] / tests / Makefile.am
index 7f3bc8eac4846001059f52e7ffd1e85f1bd4cdd4..1b44a9ccbb9711fa0d624f05ddde4bd30ca3a23d 100644 (file)
@@ -55,6 +55,9 @@ dist_check_SCRIPTS = \
        cli/test_trace_read \
        cli/test_trimmer \
        plugins/sink.text.details/succeed/test_succeed \
+       plugins/sink.text.pretty/test_enum \
+       plugins/sink.text.pretty/test_pretty.py \
+       plugins/sink.text.pretty/test_pretty_python \
        plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
@@ -106,6 +109,8 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_support_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_trace_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_metadata_info
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_assume_single_trace
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_stream_names
 endif
 endif
 
@@ -133,18 +138,24 @@ TESTS_CLI += \
        cli/test_exit_status
 
 TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming \
-       plugins/flt.utils.muxer/succeed/test_succeed
+       plugins/flt.utils.muxer/succeed/test_succeed \
+       plugins/sink.text.pretty/test_enum
 endif
 endif
 
 if HAVE_PYTHON
 TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+
+if DEV_MODE
+TESTS_LIB += lib/conds/test_conds
+endif
 endif
 
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+TESTS_PLUGINS += plugins/sink.text.pretty/test_pretty_python
 if ENABLE_DEBUG_INFO
 TESTS_PLUGINS += \
        plugins/flt.lttng-utils.debug-info/test_succeed
@@ -158,11 +169,6 @@ LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
             BT_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
-            BT_TESTS_AWK_BIN="$(AWK)" \
-            BT_TESTS_GREP_BIN="$(GREP)" \
-            BT_TESTS_PYTHON_BIN="$(PYTHON)" \
-            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
-            BT_TESTS_SED_BIN="$(SED)" \
             $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
This page took 0.023662 seconds and 4 git commands to generate.