Add a single generated env file to the test suite
[babeltrace.git] / tests / Makefile.am
index c4b0a0a507a4e2351e01d325d3cfd20a75b4f2b8..1b44a9ccbb9711fa0d624f05ddde4bd30ca3a23d 100644 (file)
@@ -1,10 +1,11 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS = \
        utils \
        lib \
        bitfield \
        ctf-writer \
        plugins \
-       argpar \
        param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
@@ -41,6 +42,10 @@ dist_check_SCRIPTS = \
        cli/convert/test_auto_source_discovery_params \
        cli/convert/test_auto_source_discovery_log_level \
        cli/convert/test_convert_args \
+       cli/list-plugins/test_list_plugins \
+       cli/params/test_params \
+       cli/query/test_query \
+       cli/test_exit_status \
        cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
@@ -50,6 +55,9 @@ dist_check_SCRIPTS = \
        cli/test_trace_read \
        cli/test_trimmer \
        plugins/sink.text.details/succeed/test_succeed \
+       plugins/sink.text.pretty/test_enum \
+       plugins/sink.text.pretty/test_pretty.py \
+       plugins/sink.text.pretty/test_pretty_python \
        plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
@@ -61,9 +69,6 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
-TESTS_ARGPAR = \
-       argpar/test_argpar
-
 TESTS_CLI = \
        cli/convert/test_convert_args \
        cli/test_help \
@@ -75,11 +80,12 @@ TESTS_CLI = \
        cli/test_trimmer
 
 TESTS_LIB = \
-       lib/test_bt_values \
        lib/test_bt_uuid \
+       lib/test_bt_values \
        lib/test_graph_topo \
-       lib/test_trace_ir_ref \
-       lib/test_simple_sink
+       lib/test_remove_destruction_listener_in_destruction_listener \
+       lib/test_simple_sink \
+       lib/test_trace_ir_ref
 
 TESTS_BITFIELD = \
        bitfield/test_bitfield
@@ -94,6 +100,7 @@ endif
 TESTS_PLUGINS = \
        plugins/src.ctf.fs/fail/test_fail \
        plugins/src.ctf.fs/succeed/test_succeed \
+       plugins/src.ctf.fs/test_deterministic_ordering \
        plugins/sink.ctf.fs/succeed/test_succeed \
        plugins/sink.text.details/succeed/test_succeed
 
@@ -102,11 +109,8 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_support_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_trace_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_metadata_info
-endif
-
-if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += \
-       plugins/flt.lttng-utils.debug-info/test_succeed
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_assume_single_trace
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_stream_names
 endif
 endif
 
@@ -124,22 +128,38 @@ endif
 
 if ENABLE_PYTHON_PLUGINS
 if ENABLE_PYTHON_BINDINGS
-TESTS_CLI += cli/convert/test_auto_source_discovery_grouping \
+TESTS_CLI += \
+       cli/convert/test_auto_source_discovery_grouping \
        cli/convert/test_auto_source_discovery_log_level \
-       cli/convert/test_auto_source_discovery_params
+       cli/convert/test_auto_source_discovery_params \
+       cli/list-plugins/test_list_plugins \
+       cli/params/test_params \
+       cli/query/test_query \
+       cli/test_exit_status
+
 TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming \
-       plugins/flt.utils.muxer/succeed/test_succeed
+       plugins/flt.utils.muxer/succeed/test_succeed \
+       plugins/sink.text.pretty/test_enum
 endif
 endif
 
 if HAVE_PYTHON
 TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+
+if DEV_MODE
+TESTS_LIB += lib/conds/test_conds
+endif
 endif
 
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+TESTS_PLUGINS += plugins/sink.text.pretty/test_pretty_python
+if ENABLE_DEBUG_INFO
+TESTS_PLUGINS += \
+       plugins/flt.lttng-utils.debug-info/test_succeed
+endif
 endif
 
 TESTS_PARAM_VALIDATION = \
@@ -149,15 +169,9 @@ LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
             BT_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
-            BT_TESTS_AWK_BIN="$(AWK)" \
-            BT_TESTS_GREP_BIN="$(GREP)" \
-            BT_TESTS_PYTHON_BIN="$(PYTHON)" \
-            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
-            BT_TESTS_SED_BIN="$(SED)" \
             $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
-       $(TESTS_ARGPAR) \
        $(TESTS_BINDINGS) \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
@@ -173,7 +187,6 @@ check-$(1):
        $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
 endef
 
-$(eval $(call check_target,argpar,$(TESTS_ARGPAR)))
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
This page took 0.024811 seconds and 4 git commands to generate.