Fix build with BUILT_IN_PLUGINS=1
[babeltrace.git] / tests / Makefile.am
index 80d8d03baf02b60d8c8f4c4fdc939f7c08c6dce7..27c904adc2cc85b2ed8b47fc8de7bf0afed925a5 100644 (file)
@@ -1,36 +1,9 @@
-SUBDIRS = utils bin lib
-
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
-
-TESTS = bin/test_trace_read \
-       bin/test_trace_read \
-       bin/test_packet_seq_num \
-       bin/test_formats \
-       bin/intersection/test_intersection \
-       lib/test_bitfield \
-       lib/test_seek_empty_packet \
-       lib/test_seek_big_trace \
-       lib/test_ctf_writer_complete \
-       lib/test_bt_values \
-       lib/test_ctf_ir_ref \
-       lib/test_bt_ctf_field_type_validation \
-       lib/test_ir_visit \
-       lib/test_trace_listener \
-       lib/test_bt_notification_heap \
-       lib/test_plugin_complete
+SUBDIRS = utils cli lib bindings
 
 EXTRA_DIST = $(srcdir)/ctf-traces/** \
             $(srcdir)/debug-info-data/** \
             $(srcdir)/debug-info-data/.build-id/cd/**
 
-if ENABLE_DEBUG_INFO
-TESTS += lib/test_dwarf_complete \
-       lib/test_bin_info_complete
-endif
-
-if USE_PYTHON
-TESTS += bin/intersection/test_multi_trace_intersection.py
-TESTS += lib/writer/test_ctf_writer_no_packet_context.py
+if !BUILT_IN_PLUGINS
+SUBDIRS += plugins
 endif
This page took 0.023118 seconds and 4 git commands to generate.