tests: Move ctf-writer to it's own directory
[babeltrace.git] / tests / Makefile.am
index 0a8f01c972bf2d27a3c5c0d9052eea89960e2662..2f5ed60e88222f276a8817b14445ad794e7f541d 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = utils lib plugins
+SUBDIRS = utils lib ctf-writer plugins
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/ctf-traces \
@@ -49,17 +49,18 @@ TESTS_CLI = \
 TESTS_LIB = \
        lib/test_bitfield \
        lib/test_bt_values \
-       lib/test_ctf_writer_complete \
        lib/test_graph_topo \
        lib/test_trace_ir_ref
 
+TESTS_CTF_WRITER = \
+       ctf-writer/test_ctf_writer
+
 if !ENABLE_BUILT_IN_PLUGINS
 TESTS_LIB += lib/test_plugin_complete
 endif
 
 if ENABLE_PYTHON_BINDINGS
 TESTS_LIB += lib/trace-ir/test_trace_ir
-TESTS_LIB += lib/ctf-writer/test_ctf_writer
 endif
 
 TESTS_PLUGINS =
@@ -95,7 +96,7 @@ endif
 LOG_DRIVER_FLAGS = '--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
 
-TESTS = $(TESTS_BINDINGS) $(TESTS_CLI) $(TESTS_LIB) \
+TESTS = $(TESTS_BINDINGS) $(TESTS_CLI) $(TESTS_CTF_WRITER) $(TESTS_LIB) \
        $(TESTS_PLUGINS) $(TESTS_PYTHON_PLUGIN_PROVIDER)
 
 define check_target
@@ -105,6 +106,7 @@ endef
 
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
+$(eval $(call check_target,ctf-writer,$(TESTS_CTF_WRITER)))
 $(eval $(call check_target,lib,$(TESTS_LIB)))
 $(eval $(call check_target,plugins,$(TESTS_PLUGINS)))
 $(eval $(call check_target,python-plugin-provider,$(TESTS_PYTHON_PLUGIN_PROVIDER)))
This page took 0.026785 seconds and 4 git commands to generate.