Tests: dynamically create test list based on enabled features
[babeltrace.git] / tests / Makefile.am
index 56e93c115ab213f74943a59059ef30a457c0f7e5..5927f59eff6a2edee32871a901277661ea9c2f10 100644 (file)
@@ -23,8 +23,12 @@ clean-local:
                done; \
        fi
 
+TEMPLIST := $(shell mktemp -u)
 check-am:
-       ./run.sh $(srcdir)/tests
+       @cat $(srcdir)/tests > $(TEMPLIST)
 if ENABLE_DEBUGINFO
-       ./run.sh $(srcdir)/tests_debuginfo
+       @echo '' >> $(TEMPLIST)
+       @cat $(srcdir)/tests_debuginfo >> $(TEMPLIST)
 endif
+       ./run.sh $(TEMPLIST)
+       rm $(TEMPLIST)
This page took 0.022648 seconds and 4 git commands to generate.