Tests: dynamically create test list based on enabled features
[babeltrace.git] / tests / Makefile.am
index 583f7ac6e7e9b6c2480e9c12698684efbaf49fbf..5927f59eff6a2edee32871a901277661ea9c2f10 100644 (file)
@@ -1,12 +1,34 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield test-dummytrace
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
 
-test_bitfield_SOURCES = test-bitfield.c
+SCRIPT_LIST = run.sh
 
-test_dummytrace_SOURCES = test-dummytrace.c
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-test_dummytrace_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+TEMPLIST := $(shell mktemp -u)
+check-am:
+       @cat $(srcdir)/tests > $(TEMPLIST)
+if ENABLE_DEBUGINFO
+       @echo '' >> $(TEMPLIST)
+       @cat $(srcdir)/tests_debuginfo >> $(TEMPLIST)
+endif
+       ./run.sh $(TEMPLIST)
+       rm $(TEMPLIST)
This page took 0.023638 seconds and 4 git commands to generate.