Tests: dynamically create test list based on enabled features
[babeltrace.git] / tests / Makefile.am
index 8d84b16b8db3e90595868130ea19de89312d88e6..5927f59eff6a2edee32871a901277661ea9c2f10 100644 (file)
@@ -1,6 +1,9 @@
 SUBDIRS = utils bin lib
 
-EXTRA_DIST = ctf-traces/** tests
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
 
 SCRIPT_LIST = run.sh
 
@@ -20,5 +23,12 @@ clean-local:
                done; \
        fi
 
+TEMPLIST := $(shell mktemp -u)
 check-am:
-       ./run.sh tests
+       @cat $(srcdir)/tests > $(TEMPLIST)
+if ENABLE_DEBUGINFO
+       @echo '' >> $(TEMPLIST)
+       @cat $(srcdir)/tests_debuginfo >> $(TEMPLIST)
+endif
+       ./run.sh $(TEMPLIST)
+       rm $(TEMPLIST)
This page took 0.024108 seconds and 4 git commands to generate.