Tests: dynamically create test list based on enabled features
[babeltrace.git] / tests / Makefile.am
index b03b7e0aa1d9ce46345e4fe8c1ea0e42ce0413ca..5927f59eff6a2edee32871a901277661ea9c2f10 100644 (file)
@@ -1,3 +1,34 @@
 SUBDIRS = utils bin lib
 
-EXTRA_DIST = ctf-traces/**
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
+
+SCRIPT_LIST = run.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+TEMPLIST := $(shell mktemp -u)
+check-am:
+       @cat $(srcdir)/tests > $(TEMPLIST)
+if ENABLE_DEBUGINFO
+       @echo '' >> $(TEMPLIST)
+       @cat $(srcdir)/tests_debuginfo >> $(TEMPLIST)
+endif
+       ./run.sh $(TEMPLIST)
+       rm $(TEMPLIST)
This page took 0.023325 seconds and 4 git commands to generate.