Clean-up: fix comment style in bin-info.c
[babeltrace.git] / tests / Makefile.am
index 583f7ac6e7e9b6c2480e9c12698684efbaf49fbf..7045aef90d8821b597a6b5839fc7e131fd15fbf2 100644 (file)
@@ -1,12 +1,22 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield test-dummytrace
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-test_bitfield_SOURCES = test-bitfield.c
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
 
-test_dummytrace_SOURCES = test-dummytrace.c
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debuginfo-data/** \
+            $(srcdir)/debuginfo-data/.build-id/cd/**
 
-
-test_dummytrace_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+if ENABLE_DEBUGINFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
This page took 0.023132 seconds and 4 git commands to generate.