bootstrap: Standardize on autoreconf -vi
[babeltrace.git] / tests / Makefile.am
index 8d84b16b8db3e90595868130ea19de89312d88e6..7045aef90d8821b597a6b5839fc7e131fd15fbf2 100644 (file)
@@ -1,24 +1,22 @@
 SUBDIRS = utils bin lib
 
-EXTRA_DIST = ctf-traces/** tests
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-SCRIPT_LIST = run.sh
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debuginfo-data/** \
+            $(srcdir)/debuginfo-data/.build-id/cd/**
 
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
-
-check-am:
-       ./run.sh tests
+if ENABLE_DEBUGINFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
This page took 0.022648 seconds and 4 git commands to generate.