bootstrap: Standardize on autoreconf -vi
[babeltrace.git] / tests / Makefile.am
index b03b7e0aa1d9ce46345e4fe8c1ea0e42ce0413ca..7045aef90d8821b597a6b5839fc7e131fd15fbf2 100644 (file)
@@ -1,3 +1,22 @@
 SUBDIRS = utils bin lib
 
-EXTRA_DIST = ctf-traces/**
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
+
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debuginfo-data/** \
+            $(srcdir)/debuginfo-data/.build-id/cd/**
+
+if ENABLE_DEBUGINFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
This page took 0.022782 seconds and 4 git commands to generate.