Clean-up: fix comment style in bin-info.c
[babeltrace.git] / tests / Makefile.am
index ff68240e854f502c2b951ebe8a6795a7ca4cf25b..7045aef90d8821b597a6b5839fc7e131fd15fbf2 100644 (file)
@@ -1,10 +1,22 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-test_bitfield_SOURCES = test-bitfield.c
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
 
-EXTRA_DIST = runall.sh ctf-traces/**
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debuginfo-data/** \
+            $(srcdir)/debuginfo-data/.build-id/cd/**
 
-check-am:
-       ./runall.sh
+if ENABLE_DEBUGINFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
This page took 0.022935 seconds and 4 git commands to generate.