Completely rework configure.ac
[babeltrace.git] / tests / Makefile.am
index 8d84b16b8db3e90595868130ea19de89312d88e6..7ae72255db6aac3cd796d213eff49df73f8e0420 100644 (file)
@@ -1,24 +1,9 @@
-SUBDIRS = utils bin lib
+SUBDIRS = utils cli lib bindings
 
-EXTRA_DIST = ctf-traces/** tests
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debug-info-data/** \
+            $(srcdir)/debug-info-data/.build-id/cd/**
 
-SCRIPT_LIST = run.sh
-
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
-
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
-
-check-am:
-       ./run.sh tests
+if !ENABLE_BUILT_IN_PLUGINS
+SUBDIRS += plugins
+endif
This page took 0.023909 seconds and 4 git commands to generate.