tests: fix Python plugin provider tests on Windows
[babeltrace.git] / tests / Makefile.am
index 877ec1c778bcc8323d2209aa65de8ccef41a3520..7ed754157910d84454677b04032e76241bfe196f 100644 (file)
@@ -1,11 +1,10 @@
-SUBDIRS = utils lib ctf-writer plugins
+SUBDIRS = utils lib bitfield ctf-writer plugins
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
             bindings/python/bt2/.coveragerc
 
 dist_check_SCRIPTS = \
-       bindings/python/bt2/test_clock_class_priority_map.py \
        bindings/python/bt2/test_clock_class.py \
        bindings/python/bt2/test_component_class.py \
        bindings/python/bt2/test_component.py \
@@ -16,6 +15,7 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_field_class.py \
        bindings/python/bt2/test_field.py \
        bindings/python/bt2/test_graph.py \
+       bindings/python/bt2/test_integer_range_set.py \
        bindings/python/bt2/test_message_iterator.py \
        bindings/python/bt2/test_message.py \
        bindings/python/bt2/test_packet.py \
@@ -55,12 +55,14 @@ TESTS_CLI = \
        cli/test_trimmer
 
 TESTS_LIB = \
-       lib/test_bitfield \
        lib/test_bt_values \
        lib/test_bt_uuid \
        lib/test_graph_topo \
        lib/test_trace_ir_ref
 
+TESTS_BITFIELD = \
+       bitfield/test_bitfield
+
 TESTS_CTF_WRITER = \
        ctf-writer/test_ctf_writer
 
@@ -75,10 +77,11 @@ TESTS_PLUGINS = \
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query
+endif
 
 if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += plugins/flt.lttng-utils.debug-info/test_lttng_utils_debug_info
-endif
+TESTS_PLUGINS += \
+       plugins/flt.lttng-utils.debug-info/test_succeed
 endif
 endif
 
@@ -96,7 +99,7 @@ endif
 
 if ENABLE_PYTHON_PLUGINS
 if ENABLE_PYTHON_BINDINGS
-TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming_wrapper
+TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming
 endif
 endif
 
@@ -113,11 +116,19 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_AWK_BIN="$(AWK)" \
             BT_TESTS_GREP_BIN="$(GREP)" \
             BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
             BT_TESTS_SED_BIN="$(SED)" \
-            $(SHELL) $(top_srcdir)/config/tap-driver.sh
+            $(SHELL) $(srcdir)/utils/tap-driver.sh
+
+TESTS_NO_BITFIELD = \
+       $(TESTS_BINDINGS) \
+       $(TESTS_CLI) \
+       $(TESTS_CTF_WRITER) \
+       $(TESTS_LIB) \
+       $(TESTS_PLUGINS) \
+       $(TESTS_PYTHON_PLUGIN_PROVIDER)
 
-TESTS = $(TESTS_BINDINGS) $(TESTS_CLI) $(TESTS_CTF_WRITER) $(TESTS_LIB) \
-       $(TESTS_PLUGINS) $(TESTS_PYTHON_PLUGIN_PROVIDER)
+TESTS = $(TESTS_NO_BITFIELD) $(TESTS_BITFIELD)
 
 define check_target
 check-$(1):
@@ -125,8 +136,12 @@ check-$(1):
 endef
 
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
+$(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
 $(eval $(call check_target,ctf-writer,$(TESTS_CTF_WRITER)))
 $(eval $(call check_target,lib,$(TESTS_LIB)))
 $(eval $(call check_target,plugins,$(TESTS_PLUGINS)))
 $(eval $(call check_target,python-plugin-provider,$(TESTS_PYTHON_PLUGIN_PROVIDER)))
+
+check-no-bitfield:
+       $(MAKE) $(AM_MAKEFLAGS) TESTS="$(TESTS_NO_BITFIELD)" check
This page took 0.028319 seconds and 4 git commands to generate.