Fix: include ctf-scanner-symbols.h to prefix yy_* symbols
[babeltrace.git] / tests / Makefile.am
index 583f7ac6e7e9b6c2480e9c12698684efbaf49fbf..8d84b16b8db3e90595868130ea19de89312d88e6 100644 (file)
@@ -1,12 +1,24 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield test-dummytrace
+EXTRA_DIST = ctf-traces/** tests
 
-test_bitfield_SOURCES = test-bitfield.c
+SCRIPT_LIST = run.sh
 
-test_dummytrace_SOURCES = test-dummytrace.c
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-test_dummytrace_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+check-am:
+       ./run.sh tests
This page took 0.022602 seconds and 4 git commands to generate.