Tests: Multi-trace stream intersection test
[babeltrace.git] / tests / Makefile.am
index 642dd983de46de4edf3a82c1bcfe73242ce6184c..98e0b85fd6730da73313166cb2a54b4ae8d64c62 100644 (file)
@@ -1,5 +1,26 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-test_bitfield_SOURCES = test-bitfield.c
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/intersection/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
+
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debuginfo-data/** \
+            $(srcdir)/debuginfo-data/.build-id/cd/**
+
+if ENABLE_DEBUGINFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
+
+if USE_PYTHON
+TESTS += bin/intersection/test_multi_trace_intersection.py
+endif
This page took 0.0226 seconds and 4 git commands to generate.