Add bt_graph_add_simple_sink_component() tests
[babeltrace.git] / tests / Makefile.am
index 4bb87daa69a8e1058e635aec202c2a80be876d08..aa48914a8ce6999b51f482fbdfd661fa76bb0167 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins
+SUBDIRS = utils lib bitfield ctf-writer plugins argpar
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -15,8 +15,11 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_field_class.py \
        bindings/python/bt2/test_field.py \
        bindings/python/bt2/test_graph.py \
+       bindings/python/bt2/test_integer_range_set.py \
+       bindings/python/bt2/test_interrupter.py \
        bindings/python/bt2/test_message_iterator.py \
        bindings/python/bt2/test_message.py \
+       bindings/python/bt2/test_package.py \
        bindings/python/bt2/test_packet.py \
        bindings/python/bt2/test_plugin.py \
        bindings/python/bt2/test_port.py \
@@ -28,7 +31,8 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_trace.py \
        bindings/python/bt2/test_value.py \
        bindings/python/bt2/utils.py \
-       cli/test_convert_args \
+       cli/convert/test_auto_source_discovery_grouping \
+       cli/convert/test_convert_args \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
        cli/test_packet_seq_num \
@@ -45,10 +49,13 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
+TESTS_ARGPAR = \
+       argpar/test_argpar
+
 TESTS_CLI = \
+       cli/convert/test_convert_args \
        cli/test_trace_read \
        cli/test_packet_seq_num \
-       cli/test_convert_args \
        cli/test_intersection \
        cli/test_trace_copy \
        cli/test_trimmer
@@ -57,7 +64,8 @@ TESTS_LIB = \
        lib/test_bt_values \
        lib/test_bt_uuid \
        lib/test_graph_topo \
-       lib/test_trace_ir_ref
+       lib/test_trace_ir_ref \
+       lib/test_simple_sink
 
 TESTS_BITFIELD = \
        bitfield/test_bitfield
@@ -76,10 +84,11 @@ TESTS_PLUGINS = \
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query
+endif
 
 if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += plugins/flt.lttng-utils.debug-info/test_lttng_utils_debug_info
-endif
+TESTS_PLUGINS += \
+       plugins/flt.lttng-utils.debug-info/test_succeed
 endif
 endif
 
@@ -97,6 +106,7 @@ endif
 
 if ENABLE_PYTHON_PLUGINS
 if ENABLE_PYTHON_BINDINGS
+TESTS_CLI += cli/convert/test_auto_source_discovery_grouping
 TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming
 endif
 endif
@@ -114,10 +124,12 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_AWK_BIN="$(AWK)" \
             BT_TESTS_GREP_BIN="$(GREP)" \
             BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
             BT_TESTS_SED_BIN="$(SED)" \
-            $(SHELL) $(top_srcdir)/config/tap-driver.sh
+            $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
+       $(TESTS_ARGPAR) \
        $(TESTS_BINDINGS) \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
@@ -132,6 +144,7 @@ check-$(1):
        $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
 endef
 
+$(eval $(call check_target,argpar,$(TESTS_ARGPAR)))
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
This page took 0.025748 seconds and 4 git commands to generate.