tests: add libbabeltrace2 pre/postcondition testing infrastructure
[babeltrace.git] / tests / Makefile.am
index c5f62e11be9920f7d7e7caa8bca80fae593ca9cf..bd7ae03d7fff8a436e579eb65a59c7c84e78b647 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS = \
        utils \
        lib \
@@ -53,6 +55,8 @@ dist_check_SCRIPTS = \
        cli/test_trace_read \
        cli/test_trimmer \
        plugins/sink.text.details/succeed/test_succeed \
+       plugins/sink.text.pretty/test_pretty \
+       plugins/sink.text.pretty/test_pretty.py \
        plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
@@ -137,12 +141,17 @@ endif
 
 if HAVE_PYTHON
 TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+
+if DEV_MODE
+TESTS_LIB += lib/conds/test_conds
+endif
 endif
 
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+TESTS_PLUGINS += plugins/sink.text.pretty/test_pretty
 if ENABLE_DEBUG_INFO
 TESTS_PLUGINS += \
        plugins/flt.lttng-utils.debug-info/test_succeed
This page took 0.023672 seconds and 4 git commands to generate.