src.ctf.fs: error out when failing to create index
[babeltrace.git] / tests / Makefile.am
index 17f6a952a1d544195a677335cfe291933a4f190a..c4b0a0a507a4e2351e01d325d3cfd20a75b4f2b8 100644 (file)
@@ -1,4 +1,11 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins argpar
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -9,7 +16,6 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_component_class.py \
        bindings/python/bt2/test_component.py \
        bindings/python/bt2/test_connection.py \
-       bindings/python/bt2/test_ctf_writer_clock.py \
        bindings/python/bt2/test_event_class.py \
        bindings/python/bt2/test_event.py \
        bindings/python/bt2/test_field_class.py \
@@ -35,12 +41,16 @@ dist_check_SCRIPTS = \
        cli/convert/test_auto_source_discovery_params \
        cli/convert/test_auto_source_discovery_log_level \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
+       cli/test_output_path_ctf_non_lttng_trace \
        cli/test_packet_seq_num \
        cli/test_trace_copy \
        cli/test_trace_read \
        cli/test_trimmer \
+       plugins/sink.text.details/succeed/test_succeed \
+       plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
        python-plugin-provider/test_python_plugin_provider.py
@@ -56,10 +66,12 @@ TESTS_ARGPAR = \
 
 TESTS_CLI = \
        cli/convert/test_convert_args \
-       cli/test_trace_read \
-       cli/test_packet_seq_num \
+       cli/test_help \
        cli/test_intersection \
+       cli/test_output_path_ctf_non_lttng_trace \
+       cli/test_packet_seq_num \
        cli/test_trace_copy \
+       cli/test_trace_read \
        cli/test_trimmer
 
 TESTS_LIB = \
@@ -80,8 +92,10 @@ TESTS_LIB += lib/test_plugin
 endif
 
 TESTS_PLUGINS = \
+       plugins/src.ctf.fs/fail/test_fail \
        plugins/src.ctf.fs/succeed/test_succeed \
-       plugins/sink.ctf.fs/succeed/test_succeed
+       plugins/sink.ctf.fs/succeed/test_succeed \
+       plugins/sink.text.details/succeed/test_succeed
 
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
@@ -118,12 +132,19 @@ TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming \
 endif
 endif
 
+if HAVE_PYTHON
+TESTS_PLUGINS += plugins/src.ctf.lttng-live/test_live
+endif
+
 TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
 endif
 
+TESTS_PARAM_VALIDATION = \
+       param-validation/test_param_validation
+
 LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
@@ -141,6 +162,7 @@ TESTS_NO_BITFIELD = \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
        $(TESTS_LIB) \
+       $(TESTS_PARAM_VALIDATION) \
        $(TESTS_PLUGINS) \
        $(TESTS_PYTHON_PLUGIN_PROVIDER)
 
This page took 0.025257 seconds and 4 git commands to generate.