tests: Move tap-driver.sh out of the autotools aux directory
[babeltrace.git] / tests / Makefile.am
index 0a8f01c972bf2d27a3c5c0d9052eea89960e2662..db0ecaef828c498c07bdd035490c5ec45fb6ac02 100644 (file)
@@ -1,12 +1,10 @@
-SUBDIRS = utils lib plugins
+SUBDIRS = utils lib bitfield ctf-writer plugins
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
-EXTRA_DIST = $(srcdir)/ctf-traces \
-            $(srcdir)/debug-info-data \
+EXTRA_DIST = $(srcdir)/data \
             bindings/python/bt2/.coveragerc
 
 dist_check_SCRIPTS = \
-       bindings/python/bt2/test_clock_class_priority_map.py \
        bindings/python/bt2/test_clock_class.py \
        bindings/python/bt2/test_component_class.py \
        bindings/python/bt2/test_component.py \
@@ -22,6 +20,7 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_packet.py \
        bindings/python/bt2/test_plugin.py \
        bindings/python/bt2/test_port.py \
+       bindings/python/bt2/test_python_bt2 \
        bindings/python/bt2/test_query_executor.py \
        bindings/python/bt2/test_stream_class.py \
        bindings/python/bt2/test_stream.py \
@@ -29,7 +28,15 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_trace.py \
        bindings/python/bt2/test_value.py \
        bindings/python/bt2/utils.py \
+       cli/test_convert_args \
+       cli/test_intersection \
+       cli/test_output_ctf_metadata \
+       cli/test_packet_seq_num \
+       cli/test_trace_copy \
+       cli/test_trace_read \
+       cli/test_trimmer \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
+       python-plugin-provider/test_python_plugin_provider \
        python-plugin-provider/test_python_plugin_provider.py
 
 TESTS_BINDINGS =
@@ -47,43 +54,51 @@ TESTS_CLI = \
        cli/test_trimmer
 
 TESTS_LIB = \
-       lib/test_bitfield \
        lib/test_bt_values \
-       lib/test_ctf_writer_complete \
+       lib/test_bt_uuid \
        lib/test_graph_topo \
        lib/test_trace_ir_ref
 
-if !ENABLE_BUILT_IN_PLUGINS
-TESTS_LIB += lib/test_plugin_complete
-endif
+TESTS_BITFIELD = \
+       bitfield/test_bitfield
 
-if ENABLE_PYTHON_BINDINGS
-TESTS_LIB += lib/trace-ir/test_trace_ir
-TESTS_LIB += lib/ctf-writer/test_ctf_writer
+TESTS_CTF_WRITER = \
+       ctf-writer/test_ctf_writer
+
+if !ENABLE_BUILT_IN_PLUGINS
+TESTS_LIB += lib/test_plugin
 endif
 
-TESTS_PLUGINS =
+TESTS_PLUGINS = \
+       plugins/src.ctf.fs/succeed/test_succeed \
+       plugins/sink.ctf.fs/succeed/test_succeed
 
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
-TESTS_PLUGINS += plugins/ctf/test_ctf_plugin
+TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query
 
 if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += plugins/test_lttng_utils_debug_info
+TESTS_PLUGINS += plugins/flt.lttng-utils.debug-info/test_lttng_utils_debug_info
 endif
 endif
 endif
 
 if ENABLE_DEBUG_INFO
 TESTS_PLUGINS += \
-       plugins/test_dwarf_i386-linux-gnu \
-       plugins/test_dwarf_powerpc-linux-gnu \
-       plugins/test_dwarf_powerpc64le-linux-gnu \
-       plugins/test_dwarf_x86_64-linux-gnu \
-       plugins/test_bin_info_i386-linux-gnu \
-       plugins/test_bin_info_powerpc-linux-gnu \
-       plugins/test_bin_info_powerpc64le-linux-gnu \
-       plugins/test_bin_info_x86_64-linux-gnu
+       plugins/flt.lttng-utils.debug-info/test_dwarf_i386-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_dwarf_powerpc-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_dwarf_powerpc64le-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_dwarf_x86_64-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_bin_info_i386-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_bin_info_powerpc-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_bin_info_powerpc64le-linux-gnu \
+       plugins/flt.lttng-utils.debug-info/test_bin_info_x86_64-linux-gnu
+endif
+
+if ENABLE_PYTHON_PLUGINS
+if ENABLE_PYTHON_BINDINGS
+TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming
+endif
 endif
 
 TESTS_PYTHON_PLUGIN_PROVIDER =
@@ -92,11 +107,25 @@ if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
 endif
 
-LOG_DRIVER_FLAGS = '--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
-
-TESTS = $(TESTS_BINDINGS) $(TESTS_CLI) $(TESTS_LIB) \
-       $(TESTS_PLUGINS) $(TESTS_PYTHON_PLUGIN_PROVIDER)
+LOG_DRIVER_FLAGS = --merge --comments
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
+            BT_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
+            BT_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
+            BT_TESTS_AWK_BIN="$(AWK)" \
+            BT_TESTS_GREP_BIN="$(GREP)" \
+            BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_SED_BIN="$(SED)" \
+            $(SHELL) $(srcdir)/utils/tap-driver.sh
+
+TESTS_NO_BITFIELD = \
+       $(TESTS_BINDINGS) \
+       $(TESTS_CLI) \
+       $(TESTS_CTF_WRITER) \
+       $(TESTS_LIB) \
+       $(TESTS_PLUGINS) \
+       $(TESTS_PYTHON_PLUGIN_PROVIDER)
+
+TESTS = $(TESTS_NO_BITFIELD) $(TESTS_BITFIELD)
 
 define check_target
 check-$(1):
@@ -104,7 +133,12 @@ check-$(1):
 endef
 
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
+$(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
+$(eval $(call check_target,ctf-writer,$(TESTS_CTF_WRITER)))
 $(eval $(call check_target,lib,$(TESTS_LIB)))
 $(eval $(call check_target,plugins,$(TESTS_PLUGINS)))
 $(eval $(call check_target,python-plugin-provider,$(TESTS_PYTHON_PLUGIN_PROVIDER)))
+
+check-no-bitfield:
+       $(MAKE) $(AM_MAKEFLAGS) TESTS="$(TESTS_NO_BITFIELD)" check
This page took 0.025381 seconds and 4 git commands to generate.