Remove Babeltrace 1 files and reorganize the tree
[babeltrace.git] / tests / Makefile.am
index 5ee5c55e8af933b9ecca296c4fa0e4f6e333ad1c..f15d6d85069bd5d9596746426aad216dbadc5ab0 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = utils bin lib
+SUBDIRS = utils bin lib bindings
 
 LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
@@ -7,7 +7,7 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
 TESTS = bin/test_trace_read \
        bin/test_trace_read \
        bin/test_packet_seq_num \
-       bin/test_formats \
+       bin/test_convert_args \
        bin/intersection/test_intersection \
        lib/test_bitfield \
        lib/test_seek_empty_packet \
@@ -19,7 +19,9 @@ TESTS = bin/test_trace_read \
        lib/test_ir_visit \
        lib/test_trace_listener \
        lib/test_bt_notification_heap \
-       lib/test_plugin_complete
+       lib/test_plugin_complete \
+       lib/test_graph_topo \
+       lib/test_cc_prio_map
 
 EXTRA_DIST = $(srcdir)/ctf-traces/** \
             $(srcdir)/debug-info-data/** \
@@ -31,5 +33,8 @@ TESTS += lib/test_dwarf_complete \
 endif
 
 if USE_PYTHON
-TESTS += bin/intersection/test_multi_trace_intersection.py
+TESTS += bin/intersection/test_multi_trace_intersection.py \
+       lib/writer/test_ctf_writer_no_packet_context.py \
+       lib/writer/test_ctf_writer_empty_packet.py \
+       bindings/python/bt2/testall.sh
 endif
This page took 0.029902 seconds and 4 git commands to generate.