Remove Babeltrace 1 files and reorganize the tree
[babeltrace.git] / tests / Makefile.am
index 9cc4a3da2ee4e6f6e7d991888f72d1df210f5a9e..f15d6d85069bd5d9596746426aad216dbadc5ab0 100644 (file)
@@ -1,11 +1,13 @@
-SUBDIRS = utils bin lib
+SUBDIRS = utils bin lib bindings
 
+LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
 TESTS = bin/test_trace_read \
        bin/test_trace_read \
        bin/test_packet_seq_num \
+       bin/test_convert_args \
        bin/intersection/test_intersection \
        lib/test_bitfield \
        lib/test_seek_empty_packet \
@@ -13,7 +15,13 @@ TESTS = bin/test_trace_read \
        lib/test_ctf_writer_complete \
        lib/test_bt_values \
        lib/test_ctf_ir_ref \
-       lib/test_bt_ctf_field_type_validation
+       lib/test_bt_ctf_field_type_validation \
+       lib/test_ir_visit \
+       lib/test_trace_listener \
+       lib/test_bt_notification_heap \
+       lib/test_plugin_complete \
+       lib/test_graph_topo \
+       lib/test_cc_prio_map
 
 EXTRA_DIST = $(srcdir)/ctf-traces/** \
             $(srcdir)/debug-info-data/** \
@@ -25,5 +33,8 @@ TESTS += lib/test_dwarf_complete \
 endif
 
 if USE_PYTHON
-TESTS += bin/intersection/test_multi_trace_intersection.py
+TESTS += bin/intersection/test_multi_trace_intersection.py \
+       lib/writer/test_ctf_writer_no_packet_context.py \
+       lib/writer/test_ctf_writer_empty_packet.py \
+       bindings/python/bt2/testall.sh
 endif
This page took 0.025713 seconds and 4 git commands to generate.