Fix: sink.ctf.fs: fix logic of make_unique_stream_file_name
[babeltrace.git] / tests / Makefile.am
index c36feb87401f1417da99bfdf0f5f31f57f13070f..f310d11b8b33d600f1b30ea856fff0d75328a695 100644 (file)
@@ -4,7 +4,6 @@ SUBDIRS = \
        bitfield \
        ctf-writer \
        plugins \
-       argpar \
        param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
@@ -54,6 +53,8 @@ dist_check_SCRIPTS = \
        cli/test_trace_read \
        cli/test_trimmer \
        plugins/sink.text.details/succeed/test_succeed \
+       plugins/sink.text.pretty/test_pretty \
+       plugins/sink.text.pretty/test_pretty.py \
        plugins/src.ctf.lttng-live/test_live \
        python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
        python-plugin-provider/test_python_plugin_provider \
@@ -65,9 +66,6 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
-TESTS_ARGPAR = \
-       argpar/test_argpar
-
 TESTS_CLI = \
        cli/convert/test_convert_args \
        cli/test_help \
@@ -108,6 +106,8 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_support_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_trace_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_metadata_info
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_assume_single_trace
+TESTS_PLUGINS += plugins/sink.ctf.fs/test_stream_names
 endif
 endif
 
@@ -147,6 +147,7 @@ TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+TESTS_PLUGINS += plugins/sink.text.pretty/test_pretty
 if ENABLE_DEBUG_INFO
 TESTS_PLUGINS += \
        plugins/flt.lttng-utils.debug-info/test_succeed
@@ -168,7 +169,6 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
-       $(TESTS_ARGPAR) \
        $(TESTS_BINDINGS) \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
@@ -184,7 +184,6 @@ check-$(1):
        $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
 endef
 
-$(eval $(call check_target,argpar,$(TESTS_ARGPAR)))
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
This page took 0.024165 seconds and 4 git commands to generate.