Tests: debug-info: compare output of `CompleteSrc`
[babeltrace.git] / tests / Makefile.am
index 6142a03b9cca90e95dc7506fc55bfc0ff3dcd80f..f8d0f788b42de34bd585847156329b8f86d90fa6 100644 (file)
@@ -1,4 +1,11 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins argpar
+SUBDIRS = \
+       utils \
+       lib \
+       bitfield \
+       ctf-writer \
+       plugins \
+       argpar \
+       param-validation
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -9,7 +16,6 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_component_class.py \
        bindings/python/bt2/test_component.py \
        bindings/python/bt2/test_connection.py \
-       bindings/python/bt2/test_ctf_writer_clock.py \
        bindings/python/bt2/test_event_class.py \
        bindings/python/bt2/test_event.py \
        bindings/python/bt2/test_field_class.py \
@@ -35,6 +41,7 @@ dist_check_SCRIPTS = \
        cli/convert/test_auto_source_discovery_params \
        cli/convert/test_auto_source_discovery_log_level \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
        cli/test_output_path_ctf_non_lttng_trace \
@@ -59,6 +66,7 @@ TESTS_ARGPAR = \
 
 TESTS_CLI = \
        cli/convert/test_convert_args \
+       cli/test_help \
        cli/test_intersection \
        cli/test_output_path_ctf_non_lttng_trace \
        cli/test_packet_seq_num \
@@ -84,6 +92,7 @@ TESTS_LIB += lib/test_plugin
 endif
 
 TESTS_PLUGINS = \
+       plugins/src.ctf.fs/fail/test_fail \
        plugins/src.ctf.fs/succeed/test_succeed \
        plugins/sink.ctf.fs/succeed/test_succeed \
        plugins/sink.text.details/succeed/test_succeed
@@ -94,11 +103,6 @@ TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_support_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_trace_info
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query_metadata_info
 endif
-
-if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += \
-       plugins/flt.lttng-utils.debug-info/test_succeed
-endif
 endif
 
 if ENABLE_DEBUG_INFO
@@ -131,7 +135,14 @@ TESTS_PYTHON_PLUGIN_PROVIDER =
 
 if ENABLE_PYTHON_PLUGINS
 TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+if ENABLE_DEBUG_INFO
+TESTS_PLUGINS += \
+       plugins/flt.lttng-utils.debug-info/test_succeed
 endif
+endif
+
+TESTS_PARAM_VALIDATION = \
+       param-validation/test_param_validation
 
 LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
@@ -150,6 +161,7 @@ TESTS_NO_BITFIELD = \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
        $(TESTS_LIB) \
+       $(TESTS_PARAM_VALIDATION) \
        $(TESTS_PLUGINS) \
        $(TESTS_PYTHON_PLUGIN_PROVIDER)
 
This page took 0.024078 seconds and 4 git commands to generate.