Fix: make check in out of tree build
[babeltrace.git] / tests / bin / Makefile.am
index e46285fbd926dac10bb1f703888691e550220e67..0245238c626a63e33591ebd3648e2963f57b2dfd 100644 (file)
@@ -1,17 +1,7 @@
-SCRIPT_LIST = test_trace_read
+noinst_SCRIPTS = test_trace_read
+CLEANFILES = $(noinst_SCRIPTS)
+EXTRA_DIST = test_trace_read.in
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
-
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
+$(noinst_SCRIPTS): %: %.in
+       sed "s#@TOPSRCDIR@#$(top_srcdir)#g" < $< > $@
+       chmod +x $@
This page took 0.022563 seconds and 4 git commands to generate.