Tests: use templates for stream intersection and packet_seq_num
[babeltrace.git] / tests / bin / Makefile.am
index e46285fbd926dac10bb1f703888691e550220e67..2bf94246a893e5c03e8283e422514a347eb94e44 100644 (file)
@@ -1,17 +1,7 @@
-SCRIPT_LIST = test_trace_read
+noinst_SCRIPTS = test_trace_read test_intersection test_packet_seq_num
+CLEANFILES = $(noinst_SCRIPTS)
+EXTRA_DIST = test_trace_read.in test_intersection.in test_packet_seq_num.in
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
-
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
+$(noinst_SCRIPTS): %: %.in
+       sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
+       chmod +x $@
This page took 0.023571 seconds and 4 git commands to generate.