Fix: Make test_dwarf and test_bin_info tests work out-of-tree
[babeltrace.git] / tests / lib / Makefile.am
index 6e48271b319e0d8d1876e3661fbcd8f710b15ce6..10fd9e734c588c34b1388c1d7ed2ac447334e327 100644 (file)
@@ -27,10 +27,8 @@ test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
 check_SCRIPTS = test_seek_big_trace \
-               test_seek_empty_packet
-SCRIPT_LIST = test_ctf_writer_complete
-EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
-CLEANFILES= test_seek_big_trace test_seek_empty_packet
+               test_seek_empty_packet \
+               test_ctf_writer_complete
 
 if ENABLE_DEBUGINFO
 test_dwarf_LDFLAGS = -static
@@ -46,21 +44,5 @@ test_bin_info_LDADD = $(LIBTAP) \
 test_bin_info_SOURCES = test_bin_info.c
 
 noinst_PROGRAMS += test_dwarf test_bin_info
-SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
+check_SCRIPTS += test_dwarf_complete test_bin_info_complete
 endif
-
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
-
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
This page took 0.023791 seconds and 4 git commands to generate.